Neu! – Die brandneue Version MultilingualPress 3.7!

Kann ich MultilingualPress in einer WordPress Single-Site Installation nutzen?

MultilingualPress in einer WordPress Single-Site Installation zu nutzen ist nicht möglich. Du benötigst für MultilingualPress zwingend eine WordPress-Multisite-Installation.

Erklärung im Detail: Darum brauchst du eine WordPress-Multisite-Installation für MultilingualPress

Um die Verwendung von MultilingualPress in einer Single-Site zu ermöglichen, müssten wir einen Eingriff vornehmen in die Art, wie WordPress Inhalte abspeichert. Es gibt Plugins, die genau das tun. Wir sind aber der Meinung, dass dies falsch ist. Denn nach Deaktivierung des Plugins würdest du den Zugriff auf deine übersetzten Inhalte verlieren.

Das gesamte Konzept von MultilingualPress baut darauf auf, je Sprache eine entsprechende Site (im WordPress-Netzwek, d.h. Multisite) zu verwenden. Verknüpfungen zwischen Sites und auch von übersetzten Inhalten (z.B. Posts oder Terme) werden in separaten Plugin-Tabellen gespeichert. Dadurch ist es möglich, in den einzelnen Sites tatsächlich nur den echten und nicht-manipulierten Inhalt (Content) zu haben, d.h. also z.B. ohne injizierte Shortcodes, wie es manche Single-Site-Plugins machen (müssen).

Solltest du eine Single-Site Installation vorliegen haben, so kannst du diese in eine Multisite umwandeln. Eine detaillierte Anleitung hierfür findest du hier.


WooCommerce & MultilingualPress & Central Stock for WooCommerce

Erstelle den perfekten mehrsprachigen Shop mit WooCommerce und unseren Plugins MultilingualPress und Central Stock for WooCommerce!